home       basis       advanced       routing       switching       testen       overig      

PT: nat demo

 

pt-nat-demo

rechts-klik en “save as” (opslaan als) op de afbeelding om de PT-oefening te downloaden
Of klikken op deze link: pt-nat-demo
 
Download de bovenstaande oefening en start ze op in PT6.2 of hoger.
De DOCSIS router uit een vorige oefening is geherconfigureerd
om NAT (network address translation) toe te passen.
  

  1. verbind alle PC’s met de switch, en zorg overal voor DHCP adressen.
     
  2. ping vanuit pc0 naar de default gateway.
     
  3. doe een NSLOOKUP naar WWW.LINUX800.BE
    (oefen geduld — het eerste pakket kan 15 seconden of langer onderweg zijn)
     
  4. doe dit opnieuw, nu in simulatie mode, en volg het pakket.
    • vergelijk de UDP en IP headers voor en achter de DOCSIS router.
       
  5. ga terug naar realtime.
    • kun je de DNS-server vanuit pc0 pingen?
    • vergelijk de headers (UDP en IP).
    • kijk indien nodig in simulatiemode waar het pakket verloren gaat.
       
  6. zet een webserver naast de DNS achter de DOCSIS, geef het correct IP-adres.
     
  7. open in simulatiemode vanuit pc1 de website.
    • volg de pakketten, en vergelijk de headers TCP en IP voor en achter de GATEWAY.
       
  8. probeer tenslotte de volgende commandos op de DOCSIS
    show ip nat statistics
    (: displays NAT statistics)
    show ip nat translations
    (: displays the NAT table)
     
  9. bekijk de configuratie:
    • netwerkkaart binnenkant (private addressing):
      interface FastEthernet0/0
      ip address 10.0.0.254 255.255.255.0
      ip nat inside
      duplex auto
      speed auto
    • netwerkkaart buitenkant (public addressing):
      interface FastEthernet0/1
      ip address 100.0.0.100 255.0.0.0
      ip nat outside
      duplex auto
      speed auto
    • nat config met access list:
      ip nat pool mypool 100.0.0.100 100.0.0.100 netmask 255.0.0.0
      ip nat inside source list 1 pool mypool overload
      !
      access-list 1 remark == [Control NAT Service]==
      access-list 1 permit 10.0.0.0 0.0.0.255