home       basis       advanced       routing       switching       testen       overig      

routing via connected network

  1. beschouw de volgende situatie:
     
    • twee netwerken
    • één router tussen beide netwerken met twee interfaces
       
      screenshot-cisco-packet-tracer-student-home-bert-desktop-routing_basics_001.pkt

       

  2. geef adressen:
     
    • geef de pc's een adres in hun respectievelijke netwerk
    • geef de router correcte ip-adressen aan beide aansluitingen Fa0/0 en Fa0/1 (zie 3 en 4)
    • stel de juiste default gateway's in op de pc's (het adres van de router in hun respectievelijke netwerk.
    • ping daarna PC-1 vanuit PC-2
       
  3. router configureren via de Command Line Interface: klik op TAB-blad CLI
     
    Dit is de meest aangewezen manier om cisco en andere routers te configureren. Deze methode werkt in principe altijd.
     
    • Hieronder zie je hoe een cisco router opstart:
      screenshot-router1

       

    • In wat volgt zie je de volledige opstart-cyclus ...
      System Bootstrap, Version 12.3(8r)T8, RELEASE SOFTWARE (fc1)
      Cisco 1841 (revision 5.0) with 114688K/16384K bytes of memory.
       
      Readonly ROMMON initialized
       
      Self decompressing the image :
      ########################################################################## [OK]
       
      Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)
      Technical Support: http://www.cisco.com/techsupport
      Copyright (c) 1986-2007 by Cisco Systems, Inc.
      Compiled Wed 18-Jul-07 04:52 by pt_team
      Image text-base: 0x60080608, data-base: 0x6270CD50
       
      Cisco 1841 (revision 5.0) with 114688K/16384K bytes of memory.
      Processor board ID FTX0947Z18E
      M860 processor: part number 0, mask 49
      2 FastEthernet/IEEE 802.3 interface(s)
      191K bytes of NVRAM.
      63488K bytes of ATA CompactFlash (Read/Write)
      Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)
      Technical Support: http://www.cisco.com/techsupport
      Copyright (c) 1986-2007 by Cisco Systems, Inc.
      Compiled Wed 18-Jul-07 04:52 by pt_team
       
       --- System Configuration Dialog ---
       
      Continue with configuration dialog? [yes/no]: no
       
      Press RETURN to get started!

       

    • Om de router als admin (root) te gebruiken, en vervolgens in configuratie modus brengen tik je het volgende in:
      Router> enable
      Router#
      Router# configure terminal 
      Enter configuration commands, one per line.  End with CNTL/Z.
      Router(config)#

       

    • In config modus kunnen we nu de twee netwerk interfaces configureren; de hier afgebeelde ip-adressen moet je vervangen door een werkende configuratie in je opdracht:
      Router(config)# Interface FastEthernet 0/0
      Router(config-if)# ip address 123.213.100.25 255.255.255.0
      Router(config-if)# no shutdown
       
      %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
       
      Router(config-if)# interface fa 0/1
      Router(config-if)# ip address 123.213.200.54 255.255.255.0
      Router(config-if)# no shutdown
       
      %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

       

    • om de modi te verlaten moeten we een paar keer exit in tikken of <CTRL><Z>
      Router(config-if)# exit
      Router(config)# exit
      Router#
      %SYS-5-CONFIG_I: Configured from console by console

       

    • om de huidige configuratie op te slaan:
      Router# copy running-config startup-config 
      Destination filename [startup-config]? <ENTER>
      Building configuration...
      [OK]
      Router# exit

       

    • om de huidige configuratie op scherm te brengen:
      Router> enable
      Router# show running-config 
      Building configuration...
       
      Current configuration : 581 bytes
      !
      version 12.4
      no service timestamps log datetime msec
      no service timestamps debug datetime msec
      no service password-encryption
      !
      hostname Router
      !
      ip cef
      no ipv6 cef
      !
      spanning-tree mode pvst
      !
      interface FastEthernet0/0
      ip address 123.213.100.25 255.255.255.0
      duplex auto
      speed auto
      !
      interface FastEthernet0/1
      ip address 123.213.200.54 255.255.255.0
      duplex auto
      speed auto
      !
      interface Vlan1
      no ip address
      shutdown
      !
      ip classless
      !
      ip flow-export version 9
      !
      line con 0
      !
      line aux 0
      !
      line vty 0 4
      login
      !
      end
       
      Router#

       

  4. router netwerk-interface configureren via de GUI van Packettracer:

    Deze methode is soms nuttig om commando's van de CLI te leren, omdat je onderaan de GUI de commando's ziet verschijnen die het invullen van velden in die GUI teweeg brengt. Het is echter van groot belang om zoveel mogelijk met de CLI (punt 3) te werken.

    screenshot-router0

     

  5. je configuratie testen
     
    • probeer nu PC-2 te pingen vanuit PC-1
      PC-1> ping 192.168.2.1
       
      Pinging 192.168.2.1 with 32 bytes of data:
       
      Request timed out.
      Reply from 192.168.2.1: bytes=32 time=1ms TTL=126
      Reply from 192.168.2.1: bytes=32 time=1ms TTL=126
      Reply from 192.168.2.1: bytes=32 time=2ms TTL=126
       
      Ping statistics for 192.168.2.1:
      Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
      Approximate round trip times in milli-seconds:
      Minimum = 1ms, Maximum = 2ms, Average = 1ms

       

      routing