home       basis       advanced       routing       switching       testen       overig      

multi area OSPF

 
Ik gebruik CBT-nuggets ICND2 - 34 t.e.m. 37 als handleiding ...
 
Multiarea wordt pas interessant als we gebruik maken van summarization.
We werken met de volgende configuratie: ...

ma-ospf

download dit sjabloon voor packettacer: ma-ospf-01

  1. ospf configuratie
     
    • BELT router
      router ospf 1
      network 10.0.0.2 0.0.0.0 area 0
      network 10.1.1.1 0.0.0.0 area 1
    • RING router
      router ospf 1
      network 10.1.1.2 0.0.0.0 area 1
    • TIE router
      router ospf 1
      network 10.0.0.1 0.0.0.0 area 0
      network 10.2.1.1 0.0.0.0 area 2
    • HAT router
      router ospf 1
      network 10.2.1.2 0.0.0.0 area 2
    • SOCK router
      router ospf 1
      network 10.0.0.3 0.0.0.0 area 0
      network 10.51.1.1 0.0.0.0 area 51
    • SHOE router
      router ospf 1
      network 10.51.1.2 0.0.0.0 area 51

       
      bekijk de huidige configuratie: ma-ospf-03
       

  2. loopback networks
     
    ik voeg 6 loopback interfaces toe aan router RING:
    int loopback 0
    ip addr 10.1.10.1 255.255.255.0
    ip ospf network point to point 
     
    int loopback 1
    ip addr 10.1.11.1 255.255.255.0
    ip ospf network point to point 
     
    int loopback 2
    ip addr 10.1.12.1 255.255.255.0
    ip ospf network point to point 
     
    int loopback 3
    ip addr 10.1.13.1 255.255.255.0
    ip ospf network point to point 
     
    int loopback 4
    ip addr 10.1.14.1 255.255.255.0
    ip ospf network point to point 
     
    int loopback 5
    ip addr 10.1.15.1 255.255.255.0
    ip ospf network point to point 

    vervolgens voeg ik deze netwerken toe als ...

    router ospf 1
    network 10.1.0.0 0.0.255.255 area 1

    zodra ik dit gedaan heb veranderen de routing tables overal zodat je de loopbacks van RING kan zien en pingen:
     
    voorbeeld op SHOE:

    SHOE-51# sh ip route
    Gateway of last resort is not set
     
     10.0.0.0/8 is variably subnetted, 10 subnets, 3 masks
    O IA    10.0.0.0/24 [110/65] via 10.51.1.1, 00:27:23, Serial0/0/0
    O IA    10.1.1.0/30 [110/129] via 10.51.1.1, 00:27:23, Serial0/0/0
    O IA    10.1.10.1/32 [110/130] via 10.51.1.1, 00:01:31, Serial0/0/0
    O IA    10.1.11.1/32 [110/130] via 10.51.1.1, 00:01:21, Serial0/0/0
    O IA    10.1.12.1/32 [110/130] via 10.51.1.1, 00:01:21, Serial0/0/0
    O IA    10.1.13.1/32 [110/130] via 10.51.1.1, 00:01:21, Serial0/0/0
    O IA    10.1.14.1/32 [110/130] via 10.51.1.1, 00:01:21, Serial0/0/0
    O IA    10.1.15.1/32 [110/130] via 10.51.1.1, 00:01:21, Serial0/0/0
    O IA    10.2.1.0/30 [110/129] via 10.51.1.1, 00:27:23, Serial0/0/0
    C       10.51.1.0/30 is directly connected, Serial0/0/0
     
    SHOE-51# ping 10.1.12.1
    Sending 5, 100-byte ICMP Echos to 10.1.12.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/11 ms

     
    vervolgens voeg ik nog telkens 6 loopback interfaces toe aan SHOE en HAT ...
     
    ... en dan vind ik op alle 6 routers nog eens 12 extra netwerken in de routing table ...
     
    bekijk de huidige configuratie: ma-ospf-05
     

  3. summarization
     
    Dit gebeurt op de ABR routers (routers met meer dan EEn AREA), in ons voorbeeld de routers in AREA 0 : BELT, TIE en SOCK
     
    Op router BELT geven we het volgende in:
    # conf t
    # router ospf 1
    # area 1 range 10.1.0.0 255.255.240.0
    # end

    Waarbij we 10.1.0.0/28 effectief hebben samengebracht in EEn netwerk.
    ...
    we doen vervolgens hetzelfde op alle ABR routers
    ...
    en vragen vervolgens de routing table op in AREA 51:

    SHOE-51# sh ip route
     
    Gateway of last resort is not set
     
     10.0.0.0/8 is variably subnetted, 10 subnets, 3 masks
    O IA    10.0.0.0/24 [110/65] via 10.51.1.1, 01:16:22, Serial0/0/0
    O IA    10.1.0.0/20 [110/129] via 10.51.1.1, 00:18:08, Serial0/0/0
    O IA    10.2.0.0/20 [110/129] via 10.51.1.1, 00:07:32, Serial0/0/0
    C       10.51.1.0/30 is directly connected, Serial0/0/0
    C       10.51.10.0/24 is directly connected, Loopback0
    C       10.51.11.0/24 is directly connected, Loopback1
    C       10.51.12.0/24 is directly connected, Loopback2
    C       10.51.13.0/24 is directly connected, Loopback3
    C       10.51.14.0/24 is directly connected, Loopback4
    C       10.51.15.0/24 is directly connected, Loopback5

     
    bekijk de volledige configuratie: ma-ospf-06
     

  4. default gateway naar het internet
     
    We simuleren een verbinding op BELT naar 94.95.96.101:
     
    BELT# interface loopback 101
    # ip addr 94.95.96.102 255.255.255.252
    BELT# ip route 0.0.0.0 0.0.0.0 94.95.96.101

     
    Daarna doen we een advertisement van de default route:

    BELT# router ospf 1
    BELT# default originate

     
    op HAT vinden we dan het volgende in de routing table:

    HAT-2> sh ip route
     
    Gateway of last resort is 10.2.1.1 to network 0.0.0.0
     
     10.0.0.0/8 is variably subnetted, 10 subnets, 3 masks
    O IA    10.0.0.0/24 [110/65] via 10.2.1.1, 01:34:22, Serial0/0/0
    O IA    10.1.0.0/20 [110/129] via 10.2.1.1, 00:31:25, Serial0/0/0
    C       10.2.1.0/30 is directly connected, Serial0/0/0
    C       10.2.10.0/24 is directly connected, Loopback0
    C       10.2.11.0/24 is directly connected, Loopback1
    C       10.2.12.0/24 is directly connected, Loopback2
    C       10.2.13.0/24 is directly connected, Loopback3
    C       10.2.14.0/24 is directly connected, Loopback4
    C       10.2.15.0/24 is directly connected, Loopback5
    O IA    10.51.0.0/20 [110/129] via 10.2.1.1, 00:22:46, Serial0/0/0
    O*E2 0.0.0.0/0 [110/1] via 10.2.1.1, 00:00:11, Serial0/0/0

    ... op de laatste regel vinden we dat we het internet op kunnen via 10.2.1.1, het adres van BELT.