home       basis       advanced       routing       switching       testen       overig      

OSPFv3 eenvoudige single area config

 

1. schema

lab79-single-area-ospfv3

 

2. adres tabel

 

PC1      -- 2b01:1234:5678:9abc::a1/64
R1-gi0/1 -- 2b01:1234:5678:9abc::11/64
 ----------------------------------------------------------
R1-gi0/0 -- 3fff:1234:abcd:beef::1/64 // link local fe80::1
R3-gi0/0 -- 3fff:1234:abcd:beef::3/64 // link local fe80::3
 ----------------------------------------------------------
R3-gi0/1 -- 2b03:1234:5678:9abc::33/64
PC3      -- 2b03:1234:5678:9abc::c3/64
 ----------------------------------------------------------
R1-lo0 -- 2a01::1/128
R1 router-ID  1.1.1.1
 ----------------------------------------------------------
R3-lo0 -- 2a03::3/128
R3 router-ID  3.3.3.3

 

3. configuratie

 

  • begin met een fysieke constructie in packettracer
  • geef hostnames aan R1 en R3
  • vergeet de ipv6 unicast-routing niet
  • geef adressen aan de twee PC's, vergeet de default gateway niet ...
  • geef adressen aan deze router interfaces: R1-gi0/1 | R3-gi0/1 | R1-gi0/0 | R3-gi0/0
  • je hoeft in principe geen link-local adressen te declareren op de Gi0/0 noch op de Gi0/1; de routers cre-eren normaal gezien zelf link-local adressen.
    R1> show ipv6 interface brief
    GigabitEthernet0/0         [up/up]
      FE80::20C:CFFF:FE7C:1801
      3FFF:1234:ABCD:BEEF::1
    GigabitEthernet0/1         [up/up]
      FE80::20C:CFFF:FE7C:1802
      2B01:1234:5678:9ABC::11
  • vergeet de OSPF declaraties niet in de router interfaces ...
    interface GigabitEthernet0/1
    ipv6 address 2B01:1234:5678:9ABC::11/64
    ipv6 ospf 1 area 0
  • kun je pingen tussen PC1 en PC3
  • kijk ook even in simulatiemode, zie je NDP paketten of router solicitations ?
  • geef een router-id 1.1.1.1 aan R1, en een router-id 3.3.3.3 aan R3
  • controlleer de werking van OSPF met show ipv6 route en show ipv6 ospf
  • voeg de Lo0 interfaces toe op R1 en R3; vind je die na een korte tijd terug in de show ipv6 route?
  • kan je pingen van een PC naar een Lo0 op de andere router?
     

4. ping ...

 

C:\> ping 2b03:1234:5678:9abc::c3
 
Pinging 2b03:1234:5678:9abc::c3 with 32 bytes of data:
Reply from 2B03:1234:5678:9ABC::C3: bytes=32 time<1ms TTL=126

 

5. show ipv6 route

 

R3> sh ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
O   2A01::1/128 [110/1]
     via FE80::1, GigabitEthernet0/0
C   2A03::3/128 [0/0]
     via Loopback0, directly connected
O   2B01:1234:5678:9ABC::/64 [110/2]
     via FE80::1, GigabitEthernet0/0
C   2B03:1234:5678:9ABC::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2B03:1234:5678:9ABC::33/128 [0/0]
     via GigabitEthernet0/1, receive
C   3FFF:1234:ABCD:BEEF::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   3FFF:1234:ABCD:BEEF::3/128 [0/0]
     via GigabitEthernet0/0, receive
L   FF00::/8 [0/0]
     via Null0, receive

 

6. show ipv6 ospf neighbor

 

R3> sh ipv6 ospf neighbor 
 
Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
1.1.1.1           1   FULL/BDR        00:00:32    1               GigabitEthernet0/0

 

7. config router R1

  
!!! R1 lab 79 configure single area OSPFv3
!
hostname R1
!
ipv6 unicast-routing
!
interface Loopback0
no ip address
ipv6 address 2a01::1/128
ipv6 ospf 1 area 0
!
interface GigabitEthernet0/0
no ip address
! ipv6 address FE80::1 link-local
ipv6 address 3fff:1234:abcd:beef::1/64
ipv6 ospf 1 area 0
no shut
!
interface GigabitEthernet0/1
no ip address
ipv6 address 2b01:1234:5678:9abc::11/64
ipv6 ospf 1 area 0
no shut
!
interface Vlan1
no ip address
shutdown
!
ipv6 router ospf 1
router-id 1.1.1.1
!
ip classless
!
end
  

8. config router R3

 
!!! R3 lab 79 configure single area OSPFv3
!
hostname R3
!
ipv6 unicast-routing
!
interface Loopback0
no ip address
ipv6 address 2a03::3/128
ipv6 ospf 1 area 0
!
interface GigabitEthernet0/0
no ip address
! ipv6 address FE80::3 link-local
ipv6 address 3fff:1234:abcd:beef::3/64
ipv6 ospf 1 area 0
no shut
!
interface GigabitEthernet0/1
no ip address
ipv6 address 2b03:1234:5678:9abc::33/64
ipv6 ospf 1 area 0
no shut
!
interface Vlan1
no ip address
shutdown
!
ipv6 router ospf 1
router-id 3.3.3.3
!
ip classless
!
end
 
 

  1. download PKT
    lab79-single-area-ospfv3